S-Tec 30 installed, but wings waggle, any ideas?

S-Tec 30 installed, but wings waggle, any ideas?

S-Tec 30 installed, but wings waggle, any ideas?

Hopefully someone here has some ideas.

Three weeks ago I had an S-Tec 30 autopilot installed in my 1957 Cessna 172.  When I cruse at below 100 Kts indicated I egt a wing rock.  It will go from left to right to left to right and so on.  Above 100 Kts it works well.  Tracks VORs or in heading mode or wing level mode.  We checked the bridal cables and they are tight.  Does anyone else have any experience with this? 

The plane has a 180hp CS (AVCON) engine upgrade and can cruise faster but I really like to save the fuel.

The altitude hold function works very well.  Solid on altitude all the time. 

The plane actually flies a little faster with the autopilot at the same power settings rather than without the autopilot engaged.  I have noticed this in many planes and it hold true here as well. 

Having the autopilot installed is the best upgrade I ever did but I am trying to get the wing waggle issue resolved and will keep you posted here, if you have any suggestions of things to check I would appreciate an email thanks!

If you also have an autopilot installed in a 172 I would love to hear comments about your experiences good or bad. 



Jeff

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

I do not have an answer for your problem but would like to know how expensive the S-Tec 30 was to install?  I have a 1960 C175 which is in the process of getting back in the air.

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

I shopped around.  Many places wanted to charge list price for the autopilot and then several thousand for installation.  Dyersburg Avionics charged a little less than list and installation was included.  Oh and they paid all taxes so the price he gave me of about $12,000.00 included it all. 

They also fixed a couple of minor problems with the plane at no charge.  After sale service has been great except for this wing waggle problem.  I suspect it is some component with the autopilot that the warrantee will take care of, the installation was top notch!

Give him a call and ask for a quote, my autopilot was altitude hold and directional, you can just get heading or altitude for a lot less.  If you do call please let him know Jeff or that you read it on Cessna Owner, I get no commission or ANYTHING from him but it is good that we Cessna and Piper owners let vendors know we keep track of each other.  Again I in no way work for this company or get any kind of kick back or anything, I mainly like him because he in inexpensive and likes older planes.  He is located at an airport in south east Missouri (M05) and is an authorized S-Tec dealer.  They has a courtesy car and low cost motels in the area.  A little over an hour driving north of Memphis. 

Please call him for a quote, because there are options that can make it cheaper or more expensive.  His shop also does annuals and other repairs. 


Dyersburg Avionics (authorized S-Tec dealer)
ask for Jerrie 573-333-4296   
or email at This e-mail address is being protected from spambots. You need JavaScript enabled to view it  


Clay Wrote:
-------------------------------------------------------
> I do not have an answer for your problem but would
> like to know how expensive the S-Tec 30 was to
> install?  I have a 1960 C175 which is in the
> process of getting back in the air.

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

Hello Clay,

I noticed you were in the market for a stec-30 autopilot. I have a stec-30 that I removed from a velocity. It has alt hold and gpss stearing, and D/G with heading bug. Everything worked perfect. I dont know if this will work for you, but will sell pretty cheep.

Thanks,
Guy Foreman
This e-mail address is being protected from spambots. You need JavaScript enabled to view it

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

Thanks for the offer but I have to spend some money on one of my tractors. The clutch pack went out yesterday. Now I have to put quite a few of my optional purchases off for quite a while.

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

Jeff,
Check that the aileron control cables have the proper tension.  Do that with the bridle cables loosened, then once again after they are installed.  A little slack in the control cables delays the control surface movement.  At slower airspeeds, it is more noticable due to slightly slower air flow.  The next step is to make sure that the roll servo is starting up at low voltages.  If it takes more than 1 to 1.5 volts, then you will get a delay in the autopilot response.

My mechanic friend added one more thing...  Is there any slop in the aileron bushings? 

good luck

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

I was a maintenance and fleet manager for a smallish Part 91 Flight School/Aircraft Rental business here in Central Texas.  My advice would be to have your mechanic replace the aileron bushings and control arm ends.  After that, part of the job would be to retension the aileron cables to factory spec.  Sounds like you have some slop in the aileron control loop;  the dutch rolling (This is the term used in light twins) is caused by turblence over the aileron surfaces at slow airspeed.
Hope this helps.

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

OIs the s-tec autopilot still for sale? If so what components do you have and how much$$$$$ for it? Thanks, Walt

Guest
Guest
useravatar
Offline
Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

Hi Walt,

Mine is not for sale.  I love this thing, little by little we are getting this waggle thing sorted out.  However Call Jerrie 573-333-4296 or email at This e-mail address is being protected from spambots. You need JavaScript enabled to view it he may have some parts for sale I do not know.  I also have seen parts on EBAY.  And Wentworth aircraft often has parts and systems for sale. Jeff


Walt Wrote:
-------------------------------------------------------
> OIs the s-tec autopilot still for sale? If so what
> components do you have and how much$$$$$ for it?
> Thanks, Walt

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

OK, Final update.  The S-Tec is all working and I love it.  The problem turned out to be in some repairs of dammage done to the airplane 25 years ago.  Anyway the installer supervised the re-rigging of the alerons, re-aligning the aleron belcranks.  Also when he was doing this he lubricated all the pullies and slides etc.  After this was done the plane flies great and I am so happy with my autopilot... Love it love it love it!!!!

FOr specifics about the alerons feel free to email me directly. 

jp

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

I can tell you another thing that can cause the wings to waggle or oscillate in a turn. I have a 172 and had an STEC-20 installed. It has taken a couple of months to find out the problem. Airplane is rigged properly. All cable tensions are correct, etc. The problem is that the wrong servo motor was sent. It apparently works too fast for my model of airplane. Hopefully, a new servor will be put in this week coming up.
Installing techs have no specs with which to check for correctness of parts, so problems are hard to get figured out.

glenndarr
useravatar
Offline
29 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

What part of the country do you live in?


jp

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

an addendum to my previous message: The servo motor provided for my autopilot is in spec, so it is correct. Now a closer examination of the turn coordinator is being done. Stay tuned!!

glenndarr
useravatar
Offline
29 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

What is the horsepower of your cessna?  And what other mods do you have?  I love my S-Tec 30, there is still a little waggle (just a tiny amount) that we never got out, but a trained butt and legs on the rudder peddals seems to work. 

My plane and I live in Arkansas.

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

I now have my airplane back. Exactly what was wrong is really not known, because a lot of little things were done to alleviate my problem. Part of the problem was that I had a Lowrance 2000 on each yoke, and that seemed to give the servo some problem when in turns. These are heavy gps units, and may have contributed to the balance of the controls in some way. Anyway, the plane does react better in turns so I am ok with things. Now, to figure a way to use the gps. The suction cup thingys are not worth a darn for trying to get them to stick to the windshield.
Thanks to all for observations and fixes.

glenndarr
useravatar
Offline
29 Posts
User info in posts
Only registered users or members can reply or post

Re: S-Tec 30 installed, but wings waggle, any ideas?

Where did you get your autopilot installed? 

Did they give you really good post-installation support? 

jp

jeffrey.puckett
useravatar
Offline
18 Posts
User info in posts
Only registered users or members can reply or post

Board Info

Board Stats:
 
Total Topics:
6042
Total Polls:
1
Total Posts:
16348
Posts this week:
1
User Info:
 
Total Users:
2495
Newest User:
desmeade@hotmail.com
Members Online:
1
Guests Online:
1830

Online: 
jwl

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked

ankara escort ankara rus escort ankara escort bayan ankara bayan partner ankara escort kizlar escort ankara ankara escort ankara eskort ankara escort bayan ankara bayan partner ankara escort kizlar escort ankara